Friendly Metal Detecting Forums   Myers Depot Metal Detectors
List all sponsors

Go Back   Friendly Metal Detecting Forums > Detectors and Gear > How to Use Your Metal Detector

Reply
  
Thread Tools Display Modes
  #1  
Old 06-23-2021, 07:46 PM
John Madill John Madill is online now
Elite Member
 
Join Date: Oct 2020
Posts: 696
Default Simplex+ won't ground balance.....

Question to fellow Simplex+ owners....

I have used the ground balance feature dozens of times with no problem.

I follow the drill of hitting the Settings button twice so it toggles past the volume function to the ground balance function.

Then i press and hold the pinpoint/confirm button and raise and lower the coil repeatedly until i hear the "ping" sound 2 or 3 times.

But now i very rarely get that "ping", even in many places i have balanced it before.

It does not seem to matter if i am in Park, Field, etc.

Any ideas? Thanks!

__________________
Simplex+, BH Discovery 3300, Nokta pulsdive, Garrett carrot

Reply With Quote


  #2  
Old 06-23-2021, 10:14 PM
Valley Hunter's Avatar
Valley Hunter Valley Hunter is offline
Senior Member
 
Join Date: Jun 2012
Location: Merced Ca.
Posts: 486
Default

Are you hitting the pinpoint button also you need to almost break your thumb pushing it in .. I do not use pinpoint .. Because I hit the power button.. backwards in others detectors
Reply With Quote


  #3  
Old 06-24-2021, 02:49 AM
jmaclen jmaclen is offline
Elite Member
 
Join Date: Dec 2018
Location: Colorado
Posts: 890
Default

Originally Posted by John Madill View post
Question to fellow Simplex+ owners....

I have used the ground balance feature dozens of times with no problem.

I follow the drill of hitting the Settings button twice so it toggles past the volume function to the ground balance function.

Then i press and hold the pinpoint/confirm button and raise and lower the coil repeatedly until i hear the "ping" sound 2 or 3 times.

But now i very rarely get that "ping", even in many places i have balanced it before.

It does not seem to matter if i am in Park, Field, etc.

Any ideas? Thanks!
Even though you don't hear a "ping" sound, do the numbers change from default 90?

Also, this sentence from the Simplex manual may explain your issue:

"If you cannot ground balance, in other words, if no beep sound is produced, it means that either the ground is too conductive or not mineralized or there is a target right below the search coil. In such a case, retry ground balance at a different spot."

__________________
Minelab GPX 5000, Equinox 800, Vanquish 440, XP Deus, Garrett 24K, Pro Pointer AT, Tek-Point, XP Mi-6

Reply With Quote


  #4  
Old 06-24-2021, 08:02 AM
John Madill John Madill is online now
Elite Member
 
Join Date: Oct 2020
Posts: 696
Default

Thanks for the replies guys.

The button for ground balance performs its other functions like pinpointing and muting.

And the machine has ground balanced these exact areas before with no problems.

And the number stays at 90.

__________________
Simplex+, BH Discovery 3300, Nokta pulsdive, Garrett carrot

Reply With Quote


  #5  
Old 06-24-2021, 10:37 AM
jmaclen jmaclen is offline
Elite Member
 
Join Date: Dec 2018
Location: Colorado
Posts: 890
Default

Originally Posted by John Madill View post
Thanks for the replies guys.

The button for ground balance performs its other functions like pinpointing and muting.

And the machine has ground balanced these exact areas before with no problems.

And the number stays at 90.
If you have tried it over absolutely clean ground with no change.....you might want to try a factory reset.

"To revert back to factory defaults please follow the steps below:
* Turn the detector on by pressing the power button.
* Once the SIMPLEX+ logo appears on the screen, press and hold down the Settings and Pinpoint/Confirm button simultaneously until 3 short beeps are heard."

__________________
Minelab GPX 5000, Equinox 800, Vanquish 440, XP Deus, Garrett 24K, Pro Pointer AT, Tek-Point, XP Mi-6

Reply With Quote


1 members found this post helpful.
  #6  
Old 06-25-2021, 11:12 AM
Dave_e's Avatar
Dave_e Dave_e is offline
Senior Member
 
Join Date: Nov 2015
Location: Ohio
Posts: 365
Default

If you have a coil cover on you may have debris inside it stopping you from ground balancing.

Make sure your coil and cover are both clean.
Reply With Quote


  #7  
Old 06-25-2021, 05:30 PM
John Madill John Madill is online now
Elite Member
 
Join Date: Oct 2020
Posts: 696
Default

I did the factory reset as suggested. It then ground balanced with a pretty drastic drop in numbers, from 90 to the mid 20's.

It was just the lawn in a Florida mobile home park. But it would not balance a 2nd time.

Mention of the coil cover rang a bell. I recently decided to forgo the coil cover and this balance problem may coincide with this change.

Any reason the absence of a cover would impact this?

The cover is several states away right now.

__________________
Simplex+, BH Discovery 3300, Nokta pulsdive, Garrett carrot

Reply With Quote


  #8  
Old 06-26-2021, 09:37 AM
gardinerdigger gardinerdigger is offline
Full Member
 
Join Date: Nov 2016
Posts: 136
Default

Can you manually set the ground balance? It's a bit more of a process but if the auto gb isn't functional it may be your only option till you can get it sorted. Page 19 in the manual will walk you through it. Good luck!
Reply With Quote


1 members found this post helpful.
Reply


Thread Tools
Display Modes

Forum Jump


All times are GMT -4. The time now is 09:47 PM.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2021, vBulletin Solutions, Inc.