Friendly Metal Detecting Forums   Deteknix
List all sponsors

Go Back   Friendly Metal Detecting Forums > Detectors and Gear > All About Detectors

Notices

Reply
  
Thread Tools Display Modes
  #1  
Old 10-09-2018, 10:37 AM
basstrackerman's Avatar
basstrackerman basstrackerman is online now
Elite Member
 
Join Date: Jan 2006
Location: Alabama
Posts: 766
Default Equinox talk

Good morning . I see alot of posts regarding the equinox behavior. For those that have counted out the equinox due to jumpy ID or chatty or whatever this is what I did.... My nox 600 that I started with was amazing.. quiet, great I'd, everything seemed to work like it should and I loved it.. well my 800 had came in so I sold the 600.. well that's when my deus became my daily machine due to some thing I hated about the nox 800.. I assumed it had a bug in software due to me knowing how awesome the 600 I had was.. so I waited..... Then an update came out so I immediately updated and took it out. I noticed pinpoint was almost perfect, modulation was alot better and it was quieter .. but ID's were not the same as dimes were iding as high as 39-40.. and some other things I knew wasn't right.. after continuing to use the Deus a and happy as can be I still was hoping for another update for my nox.... I finally just went back to old version and tested.. horrible and instantly remember why I upgraded to new version lol.. so went and updated again to the new version.. now it's like a completely new detector.. dimes ID is normal now great pinpoint, modulation, all ID's are really great.. but now I can run sensitivity at 25 with no noise!. I've only put 4-5 hours on it but I must say this is the way the nox should be working! No emi at all period.. I found a small shoe buckle a couple inches deeper than my f-pulse pinpointer with a solid id of 32-34.. very impressed with depth... So those that may have id issues or whatever try the update and he sure it went smooth..

__________________
Retired to southern Alabama. Bill

Reply With Quote


2 members found this post helpful.
  #2  
Old 10-09-2018, 05:29 PM
Trashfinder's Avatar
Trashfinder Trashfinder is offline
Supporter
 
Join Date: Oct 2012
Location: Ardmore, OK
Posts: 1,042
Default

I have had 2 the 600 and 800 both were rock solid id , pinpoint etc. I have seen posts where i know the machine is not functioning right and now i just tell them so. I think it is why we have seen a few for sale. I did the same thing when the mx sport was released , mine was a mess and i sold it as fast as i could thinking it was just a machine that was no good when all it really needed was to be fixed. There is a post right now where the nox is compared to another machine ID's in air test. I took one look and said that is not right send it in.
Reply With Quote


  #3  
Old 10-09-2018, 05:41 PM
NCtoad's Avatar
NCtoad NCtoad is offline
Supporter
 
Join Date: Sep 2016
Location: Western NC
Posts: 2,364
Default

Originally Posted by basstrackerman View post
Good morning . I see alot of posts regarding the equinox behavior. For those that have counted out the equinox due to jumpy ID or chatty or whatever this is what I did.... My nox 600 that I started with was amazing.. quiet, great I'd, everything seemed to work like it should and I loved it.. well my 800 had came in so I sold the 600.. well that's when my deus became my daily machine due to some thing I hated about the nox 800.. I assumed it had a bug in software due to me knowing how awesome the 600 I had was.. so I waited..... Then an update came out so I immediately updated and took it out. I noticed pinpoint was almost perfect, modulation was alot better and it was quieter .. but ID's were not the same as dimes were iding as high as 39-40.. and some other things I knew wasn't right.. after continuing to use the Deus a and happy as can be I still was hoping for another update for my nox.... I finally just went back to old version and tested.. horrible and instantly remember why I upgraded to new version lol.. so went and updated again to the new version.. now it's like a completely new detector.. dimes ID is normal now great pinpoint, modulation, all ID's are really great.. but now I can run sensitivity at 25 with no noise!. I've only put 4-5 hours on it but I must say this is the way the nox should be working! No emi at all period.. I found a small shoe buckle a couple inches deeper than my f-pulse pinpointer with a solid id of 32-34.. very impressed with depth... So those that may have id issues or whatever try the update and he sure it went smooth..
If I'm understanding you correctly, you're saying the first time you updated it didn't take? Did the update program say it was complete?

__________________
Tesoro Compadre 8" coil, Tesoro Mojave, Tesoro Vaquero, Minelab Equinox 800

Reply With Quote


  #4  
Old 10-09-2018, 06:50 PM
basstrackerman's Avatar
basstrackerman basstrackerman is online now
Elite Member
 
Join Date: Jan 2006
Location: Alabama
Posts: 766
Default

Originally Posted by NCtoad View post
If I'm understanding you correctly, you're saying the first time you updated it didn't take? Did the update program say it was complete?
Yes I updated it when the new nox update came out. At first I was like sweet it's working but then noticed id's were off quite bad.. it had some emi issues also.. just wasn't stable id wise and made for alot of guess work. But I decided to go back to old version 1.5 I believe. It made it worse so I redid update to the 1.74 and now it's like a completely new detector.. it's like the ones I read about.. I can run 25 sensitivity anywhere so far. And at speed 8 can still easily pick up all of my 8+ inch coin garden coins. Very happy. And now that it's working so well it most likely will take over starting roll ...

__________________
Retired to southern Alabama. Bill

Reply With Quote


  #5  
Old 10-09-2018, 09:29 PM
ZR2guy's Avatar
ZR2guy ZR2guy is offline
Elite Member
 
Join Date: Dec 2010
Location: Ohio
Posts: 1,117
Default

I never ran mine with the old software. I got it right after labor day but wasn't able to go hunting. I only took it out of the box and turned it on to make sure it worked then put it on charge. I installed the update later. I have had the EQ out quite a few times now and really like it. It operates smooth, separates targets fast, and pinpoints just fine.
The only EMI i have encountered was at a tot-lot when a woman got her cellphone out and was talking. She was only about 15-20 ft away but it was enough to cause just a little chatter; not enough to adjust sensitivity though.
I have read some bad reviews on the update but like any detector, it only performs as good as you learn it. Kinda like hearing a dog owner say his/her dog is dumb. No, I haven't met any dumb dogs but I sure have met a lot of dumb owners.

__________________
Minelab Equinox ?00

Reply With Quote


  #6  
Old 10-09-2018, 09:44 PM
basstrackerman's Avatar
basstrackerman basstrackerman is online now
Elite Member
 
Join Date: Jan 2006
Location: Alabama
Posts: 766
Default

Well it's not so much it's only as good as you learn it after update.... The update was actually faulty and most likely on my end with my laptop.. but now it's great..

__________________
Retired to southern Alabama. Bill

Reply With Quote


  #7  
Old 10-09-2018, 11:16 PM
ZR2guy's Avatar
ZR2guy ZR2guy is offline
Elite Member
 
Join Date: Dec 2010
Location: Ohio
Posts: 1,117
Default

I guess I should clarify here; I think a lot of Equinox owners need more time with this machine before they start to criticize the update, even more time before they criticize the detector itself. I am very happy with my Equinox 600 so far.
The Equinox is an extremely capable detector that yes, can be a turn-on-and-go detector which may be good enough for some but even at that leve,l there is still a decent-sized learning curve.
My only concern at this point is the battery/battery replacement. I like the rechargeable feature but I would also like the option to use regular AA alkaline batteries if I want.
I am glad to hear that yours is working great for you. Good luck and Happy Hunting

__________________
Minelab Equinox ?00

Reply With Quote


Reply


Thread Tools
Display Modes

Forum Jump


All times are GMT -4. The time now is 09:17 PM.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2019, vBulletin Solutions, Inc.