Friendly Metal Detecting Forums   Myers Depot Metal Detectors
List all sponsors

Go Back   Friendly Metal Detecting Forums > Detectors and Gear > Make It or Fix It Yourself

Reply
  
Thread Tools Display Modes
  #1  
Old 06-24-2018, 12:39 PM
Bounder Bounder is offline
Junior Member
 
Join Date: Jun 2018
Posts: 80
Default strange problem

I put this problem on another topic heading but can't remember where. The problem is with my bounty hunter quicksilver. When I got it new it went rather berserk when it was turned on. It would ratchet through all the icons and emit all the tones even when it was at rest. I discovered that it would stop doing it when I separated the batteries. It would work until the battery cases would come in contact with each other. I put a piece of plastic between them and it has worked ever since. Has anyone else ever had this and I have to wonder if it is all right?
Reply With Quote


  #2  
Old 06-24-2018, 12:54 PM
T-Man's Avatar
T-Man T-Man is online now
Elite Member
 
Join Date: Mar 2013
Location: Hamilton OH
Posts: 2,319
Default

It sounds like something is ground out internally is all I can guess. If it's still warrantied I'd send it in to be checked out. I still have mine that got me hooked on detecting that I sent into them and they turned everything around pretty quick and easy
Reply With Quote


Reply


Thread Tools
Display Modes

Forum Jump


All times are GMT -4. The time now is 01:05 PM.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2018, vBulletin Solutions, Inc.